Author Topic: running rough when warmed up  (Read 1904 times)

0 Members and 1 Guest are viewing this topic.

Nath

  • Guest
  • Trade Count: (0)
running rough when warmed up
« on: June 30, 2006, 21:44:18 PM »
Hi just hope someone can help me. I have a cally turbo tuned up with alot of goodies. When started fro m cold she goes like a monster no problems at all an ticks over fine. she boosts at 16 psi and loves it. after half an hour or so it ticks over real rough an sounds like its clogging up an missing. Also if you rev it a bit it kind of clears her out. when coming onto boost it feels like it splutters for a second then goes like a rocket usually happens at around 4000rpm. Been told it could be the lamba sensor or a temperature sensor on the thermostat houseing. These both change the way the car runs at temperature. Ive changed the plugs, dizzy, leads its a full service history car with 83000 genuine miles an doesnt smoke. Its dynoed at 279bhp. can anyone help me or had the same problem as its doing my head in.

Thanks nath

Naz

  • Guest
  • Trade Count: (0)
Re: running rough when warmed up
« Reply #1 on: June 30, 2006, 21:52:15 PM »
Have you tired adjusting the boost and lowering it a bit maybe. Could be the ECU cutting the boost when it kicks in as its runnig too much boost.

Do you have a gauge?!!!

However it doesn't explain why it does it only when hot?!!! DO you still have the cat on the car?!!! Could be blocked?!!!

Cheers

Nath

  • Guest
  • Trade Count: (0)
Re: running rough when warmed up
« Reply #2 on: June 30, 2006, 22:15:18 PM »
its not the boost mate as from cold they all boost the most. its been set up to run without a cat at power engineering. Its a mystery it only does it when warm. the only things which change with heat an how it runs when at different temps are those two things i hope...Cheers

Offline keef

  • Trade Count: (0)
  • Calibra Rookie
  • Posts: 140
  • Respect 0
  • Gender: Male
Re: running rough when warmed up
« Reply #3 on: July 01, 2006, 14:41:25 PM »
coolant temp sender is my bet it adjusts fueling based on coolant temperature. you could also try cleaning up the pins in the air mass meter. cts are about 10 quid from a factors. or get the Haynes fuel injection manual and test the resistance based on temp of water with a multimeter. range is in the book.

I had a similar problem, running like a bag o bolts when it shouldn't, bit hit and miss and not a consistant thing in my case but changed the cts and cleaned pins as said above and now she runs sweet.

Hope that helps.

Keef

Nath

  • Guest
  • Trade Count: (0)
Re: running rough when warmed up
« Reply #4 on: July 01, 2006, 21:45:02 PM »
is the coolant sensor on the thermostat houseing mate

Cheers

mad monk

  • Guest
  • Trade Count: (0)
Re: running rough when warmed up
« Reply #5 on: July 02, 2006, 08:23:07 AM »
yeh it is.blue plug 2 wires.right next to the temp gauge sender(single blue wire)

Nath

  • Guest
  • Trade Count: (0)
Re: running rough when warmed up
« Reply #6 on: July 07, 2006, 23:02:58 PM »
Ive had her on rollers today to see whats up. found out its running far to rich its of the scale on there gauge. The fuel pressure is ok though an the coolant sensor is ok. Because it is running rich it has kackered the lamba sensor. the guy who did the test reckons the ecu is to blame. its got a superchip in it which was fitted in 98 . since then we think its had the other mods done like bigger turbo an cams. he reckons its not set up for the cars mods or its buggered what do you think?. he reckons just get a standard ecu an try that so if anyones got one would be appreciated.Anyone got any suggestions could i put different chips in my ecu i need help,cheers

dj_smurph

  • Guest
  • Trade Count: (0)
Re: running rough when warmed up
« Reply #7 on: July 08, 2006, 09:27:55 AM »
the popular choices for the turbo are eds and vmax chips as long as you have a front mounted intercooler you will be impressed with the gains you might get

Offline ClubCalibra

  • Administrator
  • Trade Count: (0)
  • *
  • Posts: 5078
  • Respect 5
  • Gender: Male
    • Other Brand
Re: running rough when warmed up
« Reply #8 on: July 08, 2006, 12:01:34 PM »
Eh? I always thought the CTS was that sensor that bolts into the bottom of the engine, if you look underneath the middle of the front bumper, you can see it kind of plug downward into the bottom block?

Is it now that? If not what is that bit I've described?
* Click Here to get your ClubCalibra Window Stickers!!
* Click Here for CHEAPER CAR INSURANCE through ClubCalibra.com!
* Click Here to add your Member Pin to our map!!!
* Click Here to add your car!

Nath

  • Guest
  • Trade Count: (0)
Re: running rough when warmed up
« Reply #9 on: July 08, 2006, 13:30:14 PM »
i doesnt matter now chaps thanks for your help because its running to rich its damaged the engine an runs like a tank an makes noises from the engine like metallic sounds. Im now seeking legal advice toward who i bought it of im not having this

Offline ClubCalibra

  • Administrator
  • Trade Count: (0)
  • *
  • Posts: 5078
  • Respect 5
  • Gender: Male
    • Other Brand
Re: running rough when warmed up
« Reply #10 on: July 08, 2006, 20:19:17 PM »
I still wanna know which the CTS is now though, anyone give me a pic?
* Click Here to get your ClubCalibra Window Stickers!!
* Click Here for CHEAPER CAR INSURANCE through ClubCalibra.com!
* Click Here to add your Member Pin to our map!!!
* Click Here to add your car!

Offline keef

  • Trade Count: (0)
  • Calibra Rookie
  • Posts: 140
  • Respect 0
  • Gender: Male
Re: running rough when warmed up
« Reply #11 on: July 11, 2006, 12:25:01 PM »
on the thermostat housing, two wire device; the coolant temp sender is either blue or green. next to single wire for temp gauge

Offline ClubCalibra

  • Administrator
  • Trade Count: (0)
  • *
  • Posts: 5078
  • Respect 5
  • Gender: Male
    • Other Brand
Re: running rough when warmed up
« Reply #12 on: July 11, 2006, 17:03:25 PM »
Ahhhh right, so whats the sensor at the front (bumper side) bottom end of the engine kind of facing down into the very bottom of the ecotec?
* Click Here to get your ClubCalibra Window Stickers!!
* Click Here for CHEAPER CAR INSURANCE through ClubCalibra.com!
* Click Here to add your Member Pin to our map!!!
* Click Here to add your car!

dj_smurph

  • Guest
  • Trade Count: (0)
Re: running rough when warmed up
« Reply #13 on: July 11, 2006, 19:04:43 PM »
oil sensor