Solutions to those technical/mechanical Calibra problems. In the name of consistency, please avoid posting the same question to several different forums

  Subject / Started by Replies / Views Last post
0 Members and 5 Guests are viewing this board.
30 Replies
81478 Views
Last post July 19, 2015, 20:16:32 PM
by wim_vg
Calibra Cambelts

Started by Martin. « 1 2  All »

19 Replies
70446 Views
Last post August 27, 2013, 12:33:49 PM
by easybeast
Engine Codes

Started by Bad Kid

0 Replies
37085 Views
Last post November 04, 2009, 00:50:17 AM
by Bad Kid
0 Replies
34940 Views
Last post February 27, 2010, 11:28:27 AM
by Trigger
2 Replies
27706 Views
Last post January 11, 2016, 16:01:58 PM
by ALZ1307
3 Replies
20685 Views
Last post January 14, 2017, 19:54:47 PM
by sealeysonic
481 Replies
48173 Views
Last post August 20, 2010, 15:10:55 PM
by Dave
Fuse Box

Started by Tiggi « 1 2  All »

18 Replies
22874 Views
Last post December 29, 2013, 18:40:43 PM
by ALZ1307
SE4 to V6 - First Start Issues

Started by DanSE4 « 1 2 3 ... 12 »

176 Replies
21303 Views
Last post September 22, 2011, 21:30:50 PM
by DanSE4
49 Replies
19189 Views
Last post January 24, 2016, 02:46:46 AM
by foler
C20XE Early/Late Models?

Started by tomo_se4 « 1 2 3  All »

34 Replies
19120 Views
Last post December 10, 2008, 21:49:55 PM
by my opel
SE9 idle issue

Started by Harvey « 1 2 3 ... 7  All »

98 Replies
19031 Views
Last post May 07, 2012, 09:03:41 AM
by Laliiii
47 Replies
18183 Views
Last post December 23, 2010, 22:34:08 PM
by Teejay
C25xe crank sensor

Started by kinglee « 1 2 3 ... 5  All »

69 Replies
17501 Views
Last post November 01, 2013, 14:36:29 PM
by ALZ1307
80 Replies
17440 Views
Last post March 14, 2011, 12:25:00 PM
by shaundrw
107 Replies
17268 Views
Last post October 06, 2009, 00:12:39 AM
by carl
42 Replies
16915 Views
Last post May 21, 2010, 23:41:21 PM
by ALZ1307
8v to V6 - Question Time!

Started by DanSE4 « 1 2 3 ... 9 »

127 Replies
16828 Views
Last post April 11, 2011, 15:32:44 PM
by DanSE4
4x4 problem....

Started by tiff_lee « 1 2 3 ... 7  All »

97 Replies
16119 Views
Last post April 10, 2014, 07:56:57 AM
by callyman
C20LET mystery, help appreciated

Started by Bad Kid « 1 2 3 ... 6  All »

79 Replies
16073 Views
Last post October 16, 2008, 22:26:26 PM
by vexorg
203 Replies
15811 Views
Last post September 04, 2009, 22:19:33 PM
by Phil.
ecotec help

Started by wayneo « 1 2 3 ... 12 »

176 Replies
14959 Views
Last post March 24, 2011, 19:54:02 PM
by wayneo
52 Replies
14562 Views
Last post March 12, 2007, 20:09:01 PM
by Mr V
90 Replies
14396 Views
Last post August 18, 2009, 21:11:37 PM
by ALZ1307
Re: Turbo lag sound

Started by Dutch Calibra « 1 2 3 ... 6  All »

88 Replies
14058 Views
Last post May 01, 2008, 11:24:11 AM
by Chip

 

Normal Topic
Hot Topic (More than 15 replies)
Very Hot Topic (More than 25 replies)

Locked Topic
Sticky Topic
Poll