Solutions to those technical/mechanical Calibra problems. In the name of consistency, please avoid posting the same question to several different forums

  Subject / Started by Replies / Views Last post
0 Members and 15 Guests are viewing this board.
Re: Turbo lag sound

Started by Dutch Calibra « 1 2 3 ... 6  All »

88 Replies
11531 Views
Last post May 01, 2008, 11:24:11 AM
by Chip
4x4 problem....

Started by tiff_lee « 1 2 3 ... 7  All »

97 Replies
11059 Views
Last post April 10, 2014, 07:56:57 AM
by callyman
29 Replies
10910 Views
Last post October 16, 2008, 21:36:36 PM
by dave955
Online Haynes Manual.

Started by DrZux « 1 2  All »

24 Replies
10792 Views
Last post November 01, 2013, 21:58:45 PM
by .rip
Rear Lexus Lights...Problems

Started by charlieuk1973 « 1 2 3 ... 9 »

133 Replies
10787 Views
Last post February 14, 2008, 00:36:44 AM
by carl
PAS fluid leakage from tbox

Started by webboy « 1 2 3 ... 5  All »

67 Replies
10557 Views
Last post April 27, 2011, 12:42:13 PM
by Chip
20 Replies
10512 Views
Last post March 17, 2011, 23:18:53 PM
by geffd
C20NE poor MPG?

Started by Blackie « 1 2 3 4  All »

48 Replies
10426 Views
Last post February 26, 2011, 21:31:05 PM
by DanSE4
59 Replies
10107 Views
Last post October 16, 2011, 15:29:53 PM
by Zero-Alpha
20 Replies
10065 Views
Last post May 28, 2018, 10:50:50 AM
by Faur Sergiu
92 Replies
10059 Views
Last post July 18, 2011, 22:28:32 PM
by nms
95 Replies
9905 Views
Last post December 12, 2014, 23:05:53 PM
by [email protected]
Rough idle on C20NE

Started by wim_vg « 1 2 3  All »

33 Replies
9817 Views
Last post July 28, 2017, 17:10:01 PM
by muffly
47 Replies
9645 Views
Last post June 05, 2012, 17:01:12 PM
by DanSE4
quik fix for noisy tappets??

Started by rossisyamaha

14 Replies
9433 Views
Last post June 18, 2006, 09:18:34 AM
by rossisyamaha
Engine doesn't start when warm?

Started by Shifty « 1 2 3 ... 11 »

164 Replies
9407 Views
Last post March 31, 2009, 20:56:27 PM
by Shifty
51 Replies
9371 Views
Last post February 07, 2013, 15:29:46 PM
by zethos
37 Replies
9331 Views
Last post September 10, 2009, 22:16:39 PM
by saddy
Coolant sensor

Started by Rhino « 1 2 3  All »

38 Replies
8928 Views
Last post September 06, 2010, 02:48:24 AM
by MrCrusher
Traction control problem

Started by mickeyboy « 1 2 3 4  All »

45 Replies
8921 Views
Last post September 23, 2011, 13:29:17 PM
by DanSE4
major failure?

Started by banana man « 1 2 3 ... 9 »

123 Replies
8879 Views
Last post May 12, 2011, 13:00:40 PM
by angus346
17"s rubbing on wheel arch

Started by boobs4ever « 1 2 3  All »

42 Replies
8554 Views
Last post January 26, 2007, 16:55:24 PM
by Mr V
39 Replies
8529 Views
Last post August 14, 2011, 13:54:49 PM
by geffd
Diagnostic for X25XE

Started by geffd « 1 2 3 4  All »

50 Replies
8490 Views
Last post December 07, 2011, 14:21:23 PM
by Harvey
43 Replies
8168 Views
Last post July 24, 2012, 23:28:16 PM
by [email protected]

 

Normal Topic
Hot Topic (More than 15 replies)
Very Hot Topic (More than 25 replies)

Locked Topic
Sticky Topic
Poll