Author Topic: Fuel problem  (Read 1592 times)

0 Members and 1 Guest are viewing this topic.

Offline AlexBrasovCalibra

  • Trade Count: (0)
  • Newbie
  • Posts: 2
  • Respect 0
  • Gender: Male
    • Cally 16v Redtop
Fuel problem
« on: February 09, 2019, 15:40:26 PM »
Hello,  everyone!
I just fit a new fuel pump and new fuel filter,  and I have a problem with all this stuff.  I don't have any fuel on ramp injection, it looks like fuel pump ( external one) don't get any fuel from tank.
Can somebody give me any advice?
Car is 2.0 redtop,  c20xe engine
Many thanks

Offline TURBOHEAD

  • Trade Count: (1)
  • Calibra Rookie
  • Posts: 359
  • Respect 2
  • Gender: Male
    • Cally 16v Turbo
Re: Fuel problem
« Reply #1 on: February 09, 2019, 19:26:43 PM »
Hi

I would check the fuel filter......there are fuel direction of flow arrows marked on the filter.......the arrows should be aligned the correct way.

Next you need to check that there is a live feed going  into the fuel pump and that you have the positive and negative wire the right way around.
Also locate the fuel relay and place your fingers on top with ignition on.......you will be able to feel the relay clicking as the contacts inside connect.  If not you need to replace the fuel relay. Also don't forget to check the fuse.

Offline AlexBrasovCalibra

  • Trade Count: (0)
  • Newbie
  • Posts: 2
  • Respect 0
  • Gender: Male
    • Cally 16v Redtop
Re: Fuel problem
« Reply #2 on: February 10, 2019, 11:35:27 AM »
Hi. I checked the fuel filter flow... Same with the old one,  relay for pump it's new and I have power on both of wires.
I made one easy test... I take the pump out,  fit one hose in one fuel bottle and with 2 wires from battery,  works properly,  suck the fuel and push outside from bottle.
When I fit the pump on the right place,  don't take the fuel out from tank or bottle. 
 I suspected it's one electrical problem,  with the old pump before start the car I should switch ignition on /off for 5 times to start the car.
Relay works,  I fit a new fuse... I can't understand.
Thanks

Offline TURBOHEAD

  • Trade Count: (1)
  • Calibra Rookie
  • Posts: 359
  • Respect 2
  • Gender: Male
    • Cally 16v Turbo
Re: Fuel problem
« Reply #3 on: February 10, 2019, 11:57:06 AM »
Hi

You seam to have ruled out the fuel pump for now......fuel filter and relays etc ok.   This may be a long shot but check the earth wires attached to the fuel rail.....they could be loose but not sure if this is would effect operation.

When you turn the Ignition key to start your car.......power is sent to the fuel relay.......maybe there is a wiring problem here.  The contacts in the electrical switch part of the ignition is mounted on the opposite side of the ignition key barrel and turns when the key is turned.   You could fit a new switch to see if this is the problem.  Good Luck