Author Topic: calibra 2.0 8v running lumpy  (Read 348 times)

0 Members and 1 Guest are viewing this topic.

Offline coalman

  • Trade Count: (0)
  • Newbie
  • Posts: 3
  • Respect 0
    • Cally SE
calibra 2.0 8v running lumpy
« on: October 02, 2017, 23:07:30 PM »
Hi, can any one help me. I have a 2.0 8v calibra with 33,000 miles on clock, that has been stood for 12 years or so but has been started oftern. Tuc out for a run and it ran ok for about 40 miles and then it is pulling back like it has a fuel starvation. EML came on twice for about ten seconds then went out. Changed plugs, Dizzy cap, and rotor arm, but no change. Does any one have any idear.

Thanks Darren

Offline tristandimond

  • Trade Count: (0)
  • Calibra Rookie
  • Posts: 244
  • Respect 2
  • Gender: Male
    • Cally 16v Ecotec
Re: calibra 2.0 8v running lumpy
« Reply #1 on: October 02, 2017, 23:16:09 PM »
When does it hold back? is it over a certain rev limit?
I had a problem with mine holding back over about 3500 to 4000 revs but didn't have EML on
Had it plugged in and came up with cam sensor. Replaced it and never had any problems after
Apparently this is a common problem, may be worth trying. 
If you can get it plugged into diagnostics its well worth it as the ecu should have stored a code from the eml coming on. Luckily i had a mate who has a reader.  8)
1998 Cally 16v SE8 (daily)
1997 Cally V6 (project)
1999 Jaguar XJR 4.0 V8 Supercharged (Toy)

Offline sealeysonic

  • Trade Count: (2)
  • Calibra Mentor
  • Posts: 5785
  • Respect 6
  • Gender: Male
    • Cally SE
Re: calibra 2.0 8v running lumpy
« Reply #2 on: October 03, 2017, 05:53:18 AM »
To me it sounds like a "limp home" mode.....could be a few things....crank sensor...or similar....the 8v don't have a cam sensor......you need to do a paper clip test or get the codes read...to find out.

Online agw9262

  • Trade Count: (0)
  • Calibra Rookie
  • Posts: 273
  • Respect 4
  • Gender: Male
    • Cally 2.5i v6
Re: calibra 2.0 8v running lumpy
« Reply #3 on: October 03, 2017, 05:55:01 AM »
Did you drain and clean the fuel tank before refilling and starting/running

Offline coalman

  • Trade Count: (0)
  • Newbie
  • Posts: 3
  • Respect 0
    • Cally SE
Re: calibra 2.0 8v running lumpy
« Reply #4 on: October 04, 2017, 21:04:05 PM »
Did a paperclip test, came up code for lambda sensor. will buy a new one and try.
I did not clean out fuel tank, car had been running ok for about 45 miles with a full tank of fuel.

Thank you all for you advise

Offline vec 160

  • Trade Count: (0)
  • Newbie
  • Posts: 31
  • Respect 0
Re: calibra 2.0 8v running lumpy
« Reply #5 on: October 04, 2017, 22:41:07 PM »
Try changing the fuel filter as it may well be clogged up

HTH

Alan

Offline TURBOHEAD

  • Trade Count: (1)
  • Calibra Rookie
  • Posts: 229
  • Respect 1
  • Gender: Male
    • Cally 16v Turbo
Re: calibra 2.0 8v running lumpy
« Reply #6 on: October 06, 2017, 22:56:30 PM »
Hi

The Lambda sensor seams a good bet....when this starts to fail you will get fueling problems........so when the sensor fails the ECU uses pre-programmed fixed set of values which are adequate to run the engine but not correct for all driving conditions.

I personally would replace the fuel relay also...... as this can throw up fueling problems if it has faulty switching cycles.